Operating-Menü

GPAS: Hilfe | Operating-Menü | Rel. 1.01

Das Operating-Menü beinhaltet Dienstprogramme für die eigentliche Anwendung.

Bildschirm: Operating-Menü

Der Einstieg erfolgt über einen Login-Bildschirm. Eine entsprechende Berechtigung muss gegeben sein.

Bildschirm: Login

Für den erstmaligen Einstieg kann das Kürzel "SYS" genutzt werden.
Achtung! Bitte löschen Sie nach Anlage der eigenen Benutzerberechtigungen dieses Kürzel bzw. vergeben ein Passwort.

Der Start erfolgt über das Startprogramm (das einzige Programm mit der Endung "exe" (executable = ausführbar)) mit einem weiteren Parameter nach folgendem Muster:
aXXXX.exe /USR /O, wobei:

"a" | gewählt wurde, damit das Programm gleich vorm im Verzeichnis gefunden werden kann.
"XXXX" | für die Anwendung steht (z. B.: FiBu für Finanzbuchhaltung, Nota für Notariat, TeKa für Terminkalender etc.).
/"USR" | ein Platzhalter für das Anwenderkürzel (siehe Benutzerberechtigung) ist, und
/"O" | für den Start des OP-Menüs statt des normalen Anwendungsstarts steht.

Funktionen

An Dienstprogrammen stehen zur Verfügung:

Taste | Funktion
F1 | Hilfe
F2 | Pflege Firmenstammsatz
F3 | Pflege Benutzerberechtigung
F4 | Neuanlage der Verzeichnisse und des Datenbestandes für eine Firma
F5 | Reorganisation des Datenbestandes
F6 | internes Programm
F7 | Übersicht über aktive MitarbeiterInnen
F12 | Starten der Anwendung
Esc | Programmende

Hinweis: Die Beschreibung der Programme im OP-Menü ist allgemein gehalten, da sie in unveränderter Form in jeder beliebigen GPAS-Anwendung enthalten sind (Ausnahme: Reorganisation des Datenbestandes).


Firmenstammsatz

GPAS: Hilfe | Firmenstammsatz | Rel. 1.01

Dieses Programm bildet die Schnittstelle zwischen Soft- und Hardware.

Bildschirm: Firmenstammsatz

Bei Auslieferung des Programmpaketes ist die Datei, in der die Firmenstammsätze gepflegt werden, im Programmverzeichnis enthalten.

In diesem Programm werden folgende Felder freigegeben:

Firma

(3 St. numerisch, Mussfeld)

Hier wird die Nummer für eine Firma vergeben, unter der die Anwendung geführt werden soll.

Maschine

(3 St. numerisch, Kannfeld)

Dieses Feld hat nur in der mittleren Datentechnik eine Bedeutung.

Erweiterungs-Kz

(3 St. alphanum., Kannfeld)

Das Datei-Kennzeichen bezeichnet den Zusatz für die Dateien im Stamm-, bzw. Bewegungsdaten.
Es ist optional und findet z. Z. nur in der FiBu (Finanzbuchhaltung) Verwendung.

Sollen zentrale Stammdaten für mehrere Firmen geführt werden, muss das Kz. leer sein!

Trenn-Kz

(1 St. numerisch, Kannfeld)

Stammdaten

Library

(64 St. alphanum., Mussfeld)

Mindestens ein Zeichen und maximal 64 Zeichen muss/dürfen als Library-Bezeichnung eingegeben werden, d. h. die Dateien dürfen sich nicht im Root-Verzeichnis des Laufwerkes befinden.

Volume

(1 St. alphanum., Mussfeld)

Die Laufwerk-Bezeichnung entspricht den MS-DOS Vorgaben und kann somit in dem Bereich von 'A' bis 'Z' liegen. Bei dem Einsatz unter NetWare ist ein entsprechender 'MAP'-Befehl auszuführen. Die Neuanlage der Verzeichnisse erfolgt über das Programm 'INITFILE'.

Die Aufteilung in Stamm- und Bewegungsdaten wurde gewählt, um bei kleineren Installationen die Datensicherung zu verbessern. Die Stammdaten brauchen nur gesichert werden, wenn die Stammdaten verändert wurden.

Bewegungsdaten

Library

(Siehe Stammdaten)

Volume

(Siehe Stammdaten)

Arbeitsbereich

Library

In dieser Library werden alle temporären Dateien abgestellt, die vom Programm erzeugt werden. Die temporären Dateien werden unterschieden in:

  • a) solche, die in einem Programm benötigt werden und spätestens beim Programmende physisch gelöscht werden. Diese beginnen mit dem Präfix 'W' (Work), enthalten die 4-st. numerische Programm-Nr. und enden mit dem Benutzer-Kennzeichen, z. B. 'W8410CSG'.
  • b) solche, die weiterverarbeitet werden.

Die Namenskonvention entnehmen Sie bitte der Übersicht.

Volume

(Siehe Stammdaten)

Archivbereich

Library

(Siehe Stammdaten)

Hierher werden nicht mehr benötigte oder solche Daten ausgelagert, die sich nicht mehr verändern.

Volume

(Siehe Stammdaten)

Druckbereich

Library

(Siehe Stammdaten)

Unterhalb dieses Verzeichnisses werden vom System weitere Unterverzeichnisse generiert:

  • htm
  • pdf
  • rtf
  • txt
  • Vorlagen.

In die Druck-Library bzw. Unterverzeichnis werden alle Druckdateien abgestellt, die im Programmpaket erzeugt werden. Die Namenszusätze entnehmen Sie bitte der Übersicht 'Druck-Datei-Bezeichnung'.

Volume

(Siehe Stammdaten)

Export

Library

(siehe Stammdaten)

Hierher werden solche Daten abgestellt, die in andere Anwendungen importiert werden sollen.

Volume

(Siehe Stammdaten)

Formular-Nr'n.

(10 Felder a' 3 St. numerisch, M/K.)

Standardmäßig wird z.Z. nur der erste Tabellenplatz berücksichtigt, und zwar in allen Druckprogrammen, die keine Formschreiben erzeugen wie z. B. der Druck Zahlungsträger in der FiBu.

Der Formular-Nr. muss eine Zeilenanzahl zugeordnet werden.

Druck-Zeilen

(10 Felder a' 2 St. numerisch, M/K.)

Standardmäßig wird z. Z. in den Druckprogrammen der erste Tabellenplatz - änderbar - vorgeschlagen.

Die Werte können zwischen 30 und 99 liegen. Die Anzahl '48' entspricht 8-Zoll und die Anzahl '72' entspricht 12-Zoll Papier. PDF-Dokumente bekommen im Porträt-Format den Wert 63, im Landscape-Format den Wert 41 zugeordnet, wenn die Vorgabe größer ist.

Für Formschreiben (Mahnung, Anlage Zahlungsavis, Saldenbestätigung) wird der 3. Platz herangezogen.

Hinweis: Bei Neuanlage eines Datensatzes kann zunächst der gewählt werden, der dem Inhalt des neu anzulegenden Satzes am ehestens gerecht wird. Es wird das neue Kürzel sowie der Name überschrieben und der neue Satz abgespeichert.

Funktionen

In der Firmenstammtabelle kann auf verschiedene Weise navigiert werden:

Symbol | Taste | Funktion
 | Shift + F4 | erster Datensatz
 | F4 | vorheriger Datensatz
 | F5 | dieser Datensatz
 | F6 | nächster Datensatz
 | Shift + F6 | letzter Datensatz
 | Strg+ S | Datensatz speichern
 |  | Datensatz löschen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Benutzerberechtigung

GPAS: Hilfe | Benutzerberechtigung | Rel. 1.01
Bildschirm: Benutzerberechtigung

Für eine(n) Mitarbeiter(in) muss eine User-Id eingetragen sein, um mit der Anwendung arbeiten zu können.

Das Bedienerkürzel kann 1-3 Stellen umfassen. Es ist bewusst losgelöst von der Id, mit der man sich auf dem System angemeldet hat, da somit mehrere Id's angelegt und benutzt werden können (mehrfacher Programmaufruf nur mit verschiedenen Id's).

Im Kopfteil sind folgende Felder zur Eingabe zugelassen:

MitarbeiterIn

(3 St. alpha, Mussfeld)

Hier wird das Bedienerkürzel eingetragen

Name

(25 St. alpha, Kannfeld)

Optional kann hier der Name eingetragen werden.

OperatorIn

(1 St. alpha, Mussfeld)

Die Eingabe von (J)a oder (N)ein ist möglich.

Der Status "Operator" hat höhere Rechte als andere MitarbeiterInnen, die in den jeweiligen Programmen erläutert sind.

Info-Schlüssel

(1 St. alpha, Mussfeld)

Die Eingabe von 0 - 9 möglich.

Sofern Stammdatenprogramme über ein gleiches Feld verfügen, werden beide Einträge verglichen und der Zugriff ggf. zurückgewiesen.

Abbruch-Schlüssel

(3 St. alpha, Kannfeld)

Wird vom System beim Programmabbruch gesetzt.

Firma/Tabelle

(3 St. alpha, Kannfeld)

Erfolgt hier eine Eingabe, ist lediglich ein Zugriff entweder auf diese Firma bzw. - wenn vorhanden - auf die Firmen, die in der Firmentabelle eingetragen sind.

Zugriff auf die Jahre...

(2 * 2 St. alpha, Mussfelder)

Der Zugriff ist nur auf die Jahre möglich, die innerhalb der Felder von/bis liegen. Alle anderen Jahre sind gesperrt.

Berechtigung

(1 St. alpha, Mussfeld)

Die Eingabe von 0 bis 4 ist mit folgender Bedeutung möglich:

  • 0 = kein Zugriff auf dieses Programm bzw. Funktion innerhalb eines Programms,
  • 1 = Anzeige erlaubt,
  • 2 = Erfassen/Neuanlage von Daten möglich,
  • 3 = Ändern von Daten erlaubt,
  • 4 = Löschen bzw. Inaktivieren von Daten möglich.

Jede höhere Stufe ab 1 beinhaltet den Funktionsumfang der niedrigeren Stufen.

Diese Stufen gelten nur in den Anwendungsprogrammen, nicht in denen des Operating-Menüs!

Hinweis: Wird die Berechtigung "Update" auf 4 gesetzt,so sucht die jeweilige Anwendung automatisch nach neuen Updates. Bei Verfügbarkeit wird es im Hauptmenue eingeblendet.

Ablauf

In der Mitarbeitertabelle kann auf verschiedene Weise navigiert werden:

Symbol | Taste | Funktion
 | Shift + F4 | erster Datensatz
 | F4 | vorheriger Datensatz
 | F5 | dieser Datensatz
 | F6 | nächster Datensatz
 | Shift + F6 | letzter Datensatz
 | Enter | Datensatz anzeigen
 | Strg+ S | Datensatz speichern
 |  | Datensatz löschen
 |  | alles markieren
 |  | alles demarkieren
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende

Hinweis: Bei Neuanlage eines Datensatzes kann zunächst einer der vorhandenen gewählt werden, der dem Inhalt des neu anzulegenden Satzes am ehestens gerecht wird. Es wird das neue Kürzel sowie der Name überschrieben und der neue Satz abgespeichert.

Wurde drei Mal ein falsches Passwort eingegeben, ist der Zugriff auf die Anwendung so lange komplett gesperrt, bis die Sperre hier aufgehoben wird. Dazu das entsprechende Kürzel eingeben, den Satz anzeigen und ohne weitere Änderung speichern.


Datei- und Verzeichnisanlage

GPAS: Hilfe | Datei- und Verzeichnisanlage | Rel. 1.01

In diesem Programm werden erst- und einmalig die Verzeichnisse und Dateien für eine Firma angelegt.

Bildschirm: Datei- und Verzeichnisanlage

Eine oder mehrere Firmen sowie nebenstehende Verzeichnisse können ausgewählt werden. Durch Betätigen des Buttons (grüne Ampel) oder der ENTER-Taste wird das Programm gestartet.

Je nach Konfiguration im Firmenstammsatz können die Daten mehrerer Firmen in einem oder verschiedenen Verzeichnisen gehalten werden. Dann erübrigt sich ggf. die Anlage der Stamm- bzw. Bewegungsdaten, da diese bereits für eine andere Firma angelegt wurden. Das Arbeitsverzeichnis muss generell je Firma individuell geführt werden!

Es werden zunächst alle Verzeichnisse angelegt und dann die Dateien, die unbedingt für den Ablauf der Anwendung erforderlich sind.

Bestehende Daten werden nicht überschrieben!

Optionale Dateien werden innerhalb der Anwendung entweder automatisch oder via gesonderter Programme bereitgestellt. Jahresabhängige Dateien werden bei Bedarf im Programm: Jahreswechsel versorgt.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Reorganisation

GPAS: Hilfe | Datenreorganisation | Rel. 1.01
Bildschirm: Datenreorganisation

Sollte aus irgendeinem Grund eine Datei beschädigt sein, kann sie hier wiederhergestellt werden. In einem solchen Fall gibt es in den Programmen eine entsprechende Meldung, die den Dateinamen einschl. Laufwerk und Pfad nennt. Dazu wird der Dateistatus ausgeben, der ggf. zu notieren ist. Zuletzt erfolgt die Aufforderung, das Programm zu beenden und den EDV-Verantwortlichen zu informieren.

Es sind alle Dateien aufgelistet, die in der Anwendung angesprochen werden, unterteilt nach ihrem Speicherort.

Für die Reorganisation ist eine Datei anzuwählen. Ev. sind weitere Eingaben nötig wie beispielsweise die Jahreszahl zu einem Kalender in der Terminverwaltung.

Gleichzeitig können mehrere Dateien angewählt werden. Diese werden dann nacheinander reorganisiert. Nach Abschluß der Reorganisation wird ein Statusbericht ausgegeben, der die Datei, die Anzahl der eingelesenen und ausgegebenen Sätze enthält. Die Satzanzahl sollte natürlich identisch sein. Bei Abweichungen von > 1 sollte der Abweichung nachgegangen werden und ggf. eine anderweitige Verifizierung des Datenbestandes erfolgen.

Hinweis: Eine Datei sollte immer zuerst nach Ihrem Datenteil reorganisiert werden!

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | Reorg ausführen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


GPAS0019- aktive User

GPAS: Hilfe | aktive User | Rel. 1.01

Das Programm zeigt den Status der registierten MitarbeiterInnen.

Bildschirm: aktive User

Es werden der Name der MitarbeiterInnen sowie deren Status

  • J = aktiv oder
  • N = nicht aktiv

angezeigt.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | Eingaben übernehmen
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Installation

Diese Programme sind auf Rechnern mit einem Betriebssystem der Fa. Microsoft (Windows ™ 2000, XP, Vista oder Windows 7) lauffähig. Der Einsatz unter Windows 95, 98 oder ME sollte gleichfalls möglich sein, wird jedoch nicht mehr unterstützt.

Eine geeignete Hardware stellen gängige PC-Systeme mit Intel- (ab Pentium III) bzw. gleichwertigen Prozessoren (z. B.: AMD) dar.

An Hauptspeicher reicht der für das jeweilige Betriebssystem empfohlene aus.

Der erforderliche Festplattenspeicherplatz ist gering und sollte bei den heutigen Festplattenkapazitäten in jedem Fall vorhanden sein.

Die Programme selbst erfordern zwischen 20 und 100 MB, der erforderliche Platz für die Daten und deren Sicherung richten sich nach der Größe der Firma. Um 1 Giga zu belegen, bedarf es im Normalfall einige Jahre...

Bei der Installation selbst ist lediglich die Länge des Verzeichnises bzw. Verzeichnisbaumes zu beachten. Sie ist programmseitig auf max. 64 Stellen begrenzt!

Die Bildschirmauflösung ist mit 1024 x 768 optimal.

Es versteht sich von selbst, das den MitarbeiterInnen Schreibrechte für die Datenverzeichnisse und deren Unterordner eingeräumt werden müssen. Das gilt auch für das Programmverzeichnis, mindestens jedoch für die dort geführten Daten (s. Dateiverzeichnis).

Die Installation selbst ist nach wenigen Schritten vollzogen:

1. | Führen sie das Setup-Programm aus und folgen den Anweisungen auf dem Bildschirm. Alternativ kopieren sie alle Programme manuell in ein Verzeichnis Ihrer Wahl.
2. | Starten Sie die Anwendung!

Zu 1.
Eine gute Konvention für den Speicherort lautet beispielsweise:
x:\Programme\GPAS\Anwendung
wobei "x" für das Laufwerk und "Anwendung" für das jeweilige Programm steht.

Zu 2.
aXXXX.exe /USR /F /S /A, wobei:

"a" | gewählt wurde, damit das Programm gleich vorm im Verzeichnis gefunden werden kann.
"XXXX" | für die Anwendung steht (z. B.: FiBu für Finanzbuchhaltung, Nota für Notariat, TeKa für Terminkalender etc.).
/"USR" | ein Platzhalter für das Anwenderkürzel (siehe Benutzerberechtigung) ist, und
/"F" | für die Firma (001, 002 etc) steht,
/"S" | für den Start der Anwendung steht:
 | "O" für das Operating-Menü,
 | "B" für den Background-Taskmanager;
 | " " (ohne diesen Parameter) für alle MitarbeiterInnen.
/"A" | für die Anpassung an die Bildschirmauflösung steht.

Die Sequenz "aFiBu /ABC /002" beispielsweise steht für den Start der Finanzbuchhaltung. Als Bedienerkürzel wird "ABC", als Firma 002 mit lfd. Kalenderjahr vorgeschlagen. Bediener, Firma und Jahr können in den nachfolgenden Dialogen überschrieben werden.

Überlicherweise erfolgt die Installation auf ein Laufwerk im Netzwerk. Für den Zugriff weiterer MitarbeiterInnen reicht eine Verknüpfung mit dem Startprogramm auf deren Arbeitsplatz.
Eine Verknüpfung wird angelegt durch Klick auf die rechte Maustaste auf einer freien Stelle im Desktop oder einem Ordner. Im nachfolgenden Fenster 'Neu', 'Verknüpfung' auswählen und unter Speicherort des Elements den Namen des Startprogramms einschließlich Laufwerk und Pfad vorgeben. Die Startparameter wie oben beschrieben ergänzen.

Der Parameter für die Bildschirmauflösung dient der besseren Darstellung auf unterschiedlichen Monitoren. Die Programme sind optimiert für eine Auflösung von 1024x768. Die Darstellung auf einem Breitbandmonitor beispielsweise verzerrt die Anzeige in der Horizontalen. Durch Vorgabe eines Wertes zwischen 1 und 99 kann die Darstellung angepasst werden.

Die Programme sind multiuser- und multitaskingfäig. So kann ein(e) Miterbeiter(in) sich mit verschiedenen User-Id's mehrfach einloggen. Entsprechend greifen mehrere MitarbeiterInnen gleichzeitig auf identische Daten zu und können diese ansehen, auswerten, erweitern oder verändern.

Hinweis: Der Programmstand aus der Installation ist eine Momentaufnahme. Bitte aktualisieren Sie das Programm über die integrierte Updatefunktion, ggf. über die GPAS-Website.

Deinstallation

Da die Programme keinerlei Einträge im System vornehmen, gestaltet sich die Deinstallation entsprechend einfach.
Löschen Sie folgende Komponenten:

  • das Programmverzeichnis,
  • die Daten sowie
  • die Verknüpfung zum Programm.

Ist das Programm per Setup installiert worden, sollte die entsprechende Deinstallationsroutine genutzt werden.

Ausser der Verankerung des Application-Servers erfolgt kein Eintrag in der Registry des Windows-Systems!

Diese Aussagen gelten für alle Installationen bis zum Compiler-Release 3.1.
Danach ist die Runtime kostenpflichtig und muss als sogenannter Application-Server separat installiert werden.

Hinweis: Die lizenzfreie Laufzeitumgebung wird ab dem Jahr 2oo3 nur noch für Freeware verwandt!

Programminformation

Die GPAS-Anwendungen sind CoBOL-Programme (common business oriented language), erstellt unter NetExpress ™ von MicroFocus.

Die Programmoberfläche ist je nach Programmversion zeichenorientiert (erinnert an MS-DOS) oder grapgisch als Windows-Oberfläche oder unter einem Internetbrowser lauffähig.
Die Programmlogik ist in CoBOL erstellt.
Die Datenbasis kann die klassische Dateiverwaltung von CoBOL oder eine Datenbank sein.


System-Meldungen

GPAS: Hilfe | Fehlermeldungen (System) | Rel. 1.01

Hierbei handelt es sich um eine Aufstellung mit den Fehlermeldungen der Datenbank.

Bildschirm: Fehlermeldungen

Bei Problemen mit der Datenbank werden Fehlercodes ausgegeben. Diese werden hier erläutert.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | Anzeige aktualisieren
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Auswahlkriterien löschen

GPAS: Hilfe | Auswahlkriterien löschen | Rel. 1.01

Das Programm dient dazu, gespeicherte Vorgaben in div. Programmen auf den Ursprungszustand zurückzusetzen.

Bildschirm: Programmtabelle

Eine oder mehrere Firmen sowie nebenstehende Verzeichnisse können ausgewählt werden. Sodann sind die Felder von.../bis.. Programm zu füllen.

Durch Betätigen des Buttons (grüne Ampel) oder der ENTER-Taste wird das Programm gestartet.

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | Anzeige aktualisieren
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende


Programmtabelle

GPAS: Hilfe | Programmtabelle | Rel. 1.01

Hierbei handelt es sich um ein internes Programm, das eine Tabelle für die Benutzerberechtigung zur Verfügung stellt.

Bildschirm: Programmtabelle

Funktionen

Im Programm stehen folgende Funktionen zur Verfügung:

Symbol | Taste | Funktion
 | Enter | Anzeige aktualisieren
 |  | Reset
 | F1 | Hilfe
 | Esc | Ende